Tech Tip: Using the Vizard Package Manager to get Python 2.7 compatible versions of Python libraries

August 23, 2019

Sado Rabaudi

Vizard’s Package Manager is used to install Python add-on packages for use with Vizard's Python installation. Add-ons provide additional functionality beyond the standard Python libraries. To open the Package Manager go to Tools > Package Manager.

Package Installation

To install a package:

-Select the Search tab and type part or all of the package name in the search bar:

-Press the Install button

Vizard's interactive window will display messages that indicate whether or not the install was successful:

Python Wheel (.whl) Packages

Opening a Python .whl package in Vizard will prompt you to install the package. This is useful for downloading and installing packages from sites that are not included in the package manager search results.

Command Tab

Use the pip command bar in the Cmd tab to manually execute pip commands. This is an advanced feature typically used for non-standard installations (e.g. installing a specific package version) 

Some packages that appear in the search results are not compatible with Python 2.7, which is what Vizard uses. If this happens you may see an error such as this: 

Command "python setup.py egg_info" failed with error code 1 in c:\users\ytian\appdata\local\temp\pip-build-cisvvq\numpy\

If this happens you will need to visit the home page of the package or do a Google search to see which version will work with Python 2.7. You can also look to a site (e.g. http://www.lfd.uci.edu/~gohlke/pythonlibs/ ) with unofficial binaries.

Once you know the version you can install using the CMD tab and use the pip Command bar. 

Here is an example of this to install the version of matplotlib that works with Python 2.7: 

Select the Cmd tab and type install matplotlib==2.2.4 in the pip field:




Here is a list of a few common Python libraries and the version needed for Python 2.7: 


Numpy: 

install numpy==1.16.4

 

Scipy: 

install scipy==1.2.2 

 

Matplotlib

install matplotlib==2.2.4